LAMP Consortium

Error on Connection

Hello,

I’m trying to deploy MindLAMP on AWS server with MongoDB as the database and I found this connection error as in the following screenshot.

I also have some questions regarding the deployment.

  1. Should I download the source codes from the MindLAMP github repositories? If yes, where should I put them in?
  2. During testing, I typed this command “curl -k https://api.example.com/researcher -H ‘Authorization: Basic admin:admin’” but I think my server doesn’t have “researcher” page. Is that related to my first question and do you know where to start debug this problem?

Thanks!

The error looks like Self-Hosting Deployment Questions with CENTOS - #2 by jeyraman which has been answered. The past posts are really helpful to me.

  1. if you want to customise and deploy your own version, you can folk it on Github and set up your own docker hub repo.
  2. not enough info for me to understand. I suppose you follow the docker stack lamp.yml on the instructions to make sure all docker services are working and use portainer which is really helpful on deployment debug.

Thanks for your reply! I have checked out the past posts and installed Redis and NATS. The same error still appears.

  1. Got it!
  2. I was following the instructions and it looks like the server is running. Yet I’m not sure what to expect after I run this command "“curl -k https://api.example.com/researcher -H ‘Authorization: Basic admin:admin’”. Can you give an example output of what happens if I run that command? I got the following result (screenshot) after I ran it.

Thanks!


Above is my curl result.

what is the result of your curl db.example.com according to Testing the LAMP Platform | LAMP Platform
have you curl test your db, API, did you retrieve your admin password from docker logs

  1. Verify the status of the CouchDB database.

curl -k https://admin:DB_PASSSWORD_HERE@db.example.com/

  1. Verify the status of the LAMP Platform API Server.

curl -k https://api.example.com/

Thanks for your reply and the screenshot!

  1. I curl test my db with this command:
    curl -k http://admin:DB_PASSSWORD_HERE@localhost/

since my MongoDB is run on the localhost.

The output is the Apache2 Ubuntu default page.

  1. When I run curl for the LAMP Platform API Server, the output is also Apache2 Ubuntu default page.

I didn’t retrieve any admin password.

Should I create a database called “researcher” manually?

Thanks!