Cortex troubleshooting

hi! is there still a bug in the cortex code? i have been getting the same error message as before when there was a bug but i was under the impression that it had been fixed:

cortex.run(‘me’, [‘screen_state’], start=0, end=cortex.now())[‘screen_state’].to_csv(’~/export.csv’, index=False)
[INFO:feature_types:_wrapper2] Cortex caching directory set to: /Users/melanienisenson/.cache/cortex
[INFO:feature_types:_wrapper2] Processing raw feature “lamp.screen_state”…
Traceback (most recent call last):
File “”, line 1, in
File “/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/cortex/run.py”, line 61, in run
_res = func_list[f][‘callable’](
File “/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/cortex/feature_types.py”, line 78, in _wrapper2
saved[‘start’] = int(saved[‘start’])
ValueError: invalid literal for int() with base 10: ‘U0624097060’

@rhays hi sorry still wondering!

Hi @mnisenson have you tried updating via pip install --upgrade LAMP-cortex? This bug should be fixed with the most recent release; if not, we will look into it further

ah ok thank you! i upgraded and the accelerometer data has been coming through fine but i’m still having issues with screen state and survey data. its just [‘survey’] or [‘screen_state’] correct? im downloading by participant id individually since i was not able to download by study id (not sure if that bug has been fixed or if its user error). thanks!

@rhays oops i keep forgetting to tag you in the reply

@rhays @avaidyam please help !

Hi, sorry for the egregious delay. I’m working on this today and will post a fix asap

1 Like

Hi Just want to report that we encountered the same issue. hope there will be a quick fix soon.

Ps: have tried pip install --upgrade LAMP-cortex and i believe everything is at the latest version.

1 Like