LAMP Consortium

Adding sensors

Hi all,

I am having problems adding any sensors, when I try to add a sensor, it appears as a cognitive task under Activity. I would really like to be able to measure physical and social activity (steps, sms, calls, etc) for patients already enrolled in our ongoing projects.

I would also like to know how the accelerometer motion data can be used, whether it can indicate physical activity at all, as that seems to be the only sensor data I can collect with this platform at the moment.

Further, I am not able to see the dashboard update yet.

Many thanks for any advice or help!

Laurel

1 Like

Hi Laurel,

The update has not been released yet, but once it is (hopefully this week) the sensor issue should be resolved and you will see the updated dashboard. I will be sending an email to consortium members to notify about the update and a training webinar that will follow shortly.

In terms of accelerometer data, you can use it for physical activity. Our team has code that can accomplish this, but you would need to run it yourself. Please let me know if this is of interest to you!

Best,

Rebecca

Hi Rebecca, thanks so much, that’s great. Yes I’d definitely be interested in running that code if you’d be willing to share it.

Many thanks again,
Laurel

hi @rbilden just to clarify: while waiting for the update to be released, does the mindLAMP 2 app collect sms/texts, calls, wifi and other “social” activities? For iOS in particular, do we need to enable permissions to collect the information mentioned above (lamp.calls, lamp.sms, lamp.wifi).
Thank you.

Hi Nicholai,

All data will continue to be collected now and once LAMP has updated. Since you are on your own server you should not need to update sensor permissions for existing studies after the update as your settings should not change. Any new studies will need sensors to be enabled manually going forward.

Best,

Rebecca

Thanks @rbilden. At the moment, I am having the same issue as @laurelmorris: I don’t see any data related to calls, sms, or wifi. I asked my question to ensure that this is not an error on our server or something we neglected to configure.
Should we see “social activity” data even before the updates this week? Thank you!

Hi @nicholaide have you seen any “social activity” data now that the update is released?

Hi @rbilden, not yet. The new interface is working, but when adding a sensor, the dropdown for the sensor spec is empty. Do we have to configure this on the backend for an existing study? Thank you!

1 Like

Hi @nicholaide, please see this issue: https://github.com/BIDMCDigitalPsychiatry/LAMP-platform/issues/119

If you are still running into problems, please make a GitHub issue!

Hi all, I am still not seeing the new interface even after the backend has been updated yesterday (version is listed as 192 and was created on 02-23-2021). Is there anything else that needs to be done to get the update? thanks!

1 Like

@laurelmorris my web browser cached the old interface. Clear your cache or use a different browser to verify.

1 Like

@laurelmorris Considering we are now well into the 900s for the dashboard version you may be significantly out of date. If your team is deploying a separate copy of the dashboard please let them know to upgrade it!

Hi Nicholai, that worked, thank you!

I can see the new dashboard and when I log in as admin it works fine. Although when I switch to Researcher view the screen is constantly loading.

Aditya, I checked with our developer if he can upgrade again based on the latest dashboard versions, thanks.

2 Likes

Hi Nicholai, Aditya,

Quick update: I cleared all cache/histories, tried several browsers, tried a novel computer, and still just have a constant ‘loading’ screen in the researcher view. Since the admin view is fine I created a new researcher but have the same issue.

Aditya: to clarify regarding versions, we are not hosting our own front-end/dashboard, we are using your front-end/dashboard (https://dashboard.lamp.digital), but we are hosting our own backend/api which is located at api.morrislab-lamp.com. Our backend is updated to the most recent version, which is currently version 192. So do we need to worry about the version number of the dashboard, since we’re not hosting our own?

Hi @laurelmorris - this is likely because your backend is not updated yet. If you send us (myself and @rbilden) a private message or email and CC your IT team responsible for deployment, we can explain this process in a little bit more detail and it should not take much effort or time!

(This is because of a recent change that occurred in the backend - it will not be the case in the future where you have to update the backend each time to use new dashboard features.)