LAMP Consortium

Problem advancing surveys with textbox questions

Issue:
If my survey has a “Textbox” question immediately followed by either a “Yes or No” or “Likert Response” question, the survey will not advance to the next page or allow me to submit the survey if that was the last page.

Also, if I include a “Textbox” question immediately after one of several different question types (e.g. “Years”) it either doesn’t allow submission and/or advancing to the next page of the survey. I have not tried all of the permutations of this behavior to see when it does or does not work.

Environment:
iPhone 7, iOS 12.4, mindLAMP version 1.0.19.0

Hi @EricMiller,

Do you know if this issue occurs for you in Android devices? It would be helpful if you could provide a screenshot of the survey during the bug occurring too.

Thanks so much for the feedback!

@avaidyam I don’t have access to an Android device, so I don’t know the behavior there.

Here is one instance of the bug in which I have a textbox question followed by a Yes/No question. The ‘Submit’ button is not visible or accessible below the Yes/No question.

I also tried including a second Yes/No question (Textbox->Yes/No->Yes/No), and it looks the same as above, only this time it does not continue to the next page, so I never see the third question.

And here is a different instance, where I have a Years question followed by a Textbox question. Here, the ‘Submit’ button is visible but nothing happens when I click on it (i.e. it will not trigger a submission).

Hi @EricMiller,

Thank you for the detailed feedback! I’ll have our developers take a look at this. I’ll let you know as we receive a more detailed ETA but I would estimate sometime March. Please work around this issue until I get more information back to you.

Thanks again.

1 Like

Hi @EricMiller,

Unfortunately we don’t have an ETA yet but we have narrowed it down to the fact that a text box question must be the only question on the page, otherwise it fails to validate correctly. This means either it is the ONLY question in the survey or the very LAST question of the survey, right now. @phenson was able to replicate this issue in a different environment as well, and hopefully our developers can solve the problem very soon!

Thanks again for your help in finding this unique bug!

Hi @avaidyam, thanks for the response. No problem about taking more time on it. We are not particularly pressed for time on our end.

@EricMiller ETA on this fix is next week. Thanks for bringing it to our attention!